How to boot Windows DVD in UEFI mode?

Discussion in 'Windows 7' started by Stannieman, Aug 14, 2011.

  1. Stannieman

    Stannieman MDL Guru

    Sep 4, 2009
    2,231
    1,783
    90
    #1 Stannieman, Aug 14, 2011
    Last edited: Aug 14, 2011
    I got my new notebook from friday. As to be expected it's full of crap I never use, so I'll reïnstall windows.
    Currently the hdd has MBR layout (because of recovery partition stuff?).
    Anyway, I want to switch to GPT when doing the reinstall.
    I don't expect problems with erasing the hdd and making it GPT. The problem is that I can't get the dvd to boot in UEFI mode.
    The windows setup files are on a bootable usb. When I open the boot menu I can boot the usb key, but I think it boots in bios mode then?
    When I enable UEFI boot in setup, there's an additional option "UEFI: USB USB...", I suppose that this is the option I need to choose? But when using this option it shows a new setup screen for some miliseconds (to fast to see what it is) and then it just boots into windows on the hdd.

    It should also be possible to boot the usb key with a command in the efi shell, but when I choose the option in the setupscreen to start the shell from filesystem it says there isn't any. I think there is no efi partition at all, can someone tell me what's the best way to get a working efi shell to get the dvd to boot correctly?

    Thanks in advance
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  2. Tito

    Tito Super Mod / Adviser
    Staff Member

    Nov 30, 2009
    16,587
    13,831
    340
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. Stannieman

    Stannieman MDL Guru

    Sep 4, 2009
    2,231
    1,783
    90
    #3 Stannieman, Aug 15, 2011
    Last edited: Aug 16, 2011
    The forced efi usb boots, but is there a way to check if it's really in efi mode, or is checking if it installs on the gpt disk the only way to do it?

    EDIT:
    I booted using the forced efi usb and opened cmd (alt + F10). Then I ran diskpart, cleaned the disk and did "convert GPT", the process went successful and when running the list disk command it indicates it's a gpt disk.

    Then I proceed with the install, but when windows is installed the disk is MBR style again, so apparently the dvd doesn't boot in efi mode at all and simply decides to convert the drive to MBR again.

    I'm pretty sure how that the UEFI: USB USB HARDDISK option in the boot menu is the uefi mode of the usb with windows files. When selecting that option it immediately shows the same bootmenu again but with the harddisk selected, then it boots windows from the hdd, or the MBR mode of the usb key if the hdd is empty.
    So I just need to get the uefi mode to work. Could it be cause I use a usb key instead of a real dvd?

    EDIT2:
    Ok I got it sorted out, I just had to burn it. My mainboard can't boot from efi based usb devices.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...